Top 10 funkcji Excel

Zaktualizowano: 12 mar

Czyli subiektywny ranking funkcji. Jednostronicowy PDF do pobrania.


W Excelu jest ponad 450 funkcji. Czy używam ich wszystkich?


Szacuje, że w swojej pracy używam na co dzień 20-30. Kolejne 50 używam sporadycznie. Często zaś wyszukuje na blogach tematycznych jak rozwiązać nurtujące mnie zagadnienie, jaką funkcję użyć. Zadaje pytania na blogach, radzę się innych użytkowników, oglądam filmiki. Excel to takie narzędzie, którego nie sposób odkryć w zupełności. Daje nieskończoną ilość rozwiązań.

W tym wpisie zebrałam moje top 10 funkcji a na samym końcu można pobrać jednostronicowy PDF - 10 funkcji Excel w pigułce.


Aplikacje w Excelu sprawdź:



Dla początkujących użytkowników, Excel przygotował szereg usprawnień.

  1. Lista wszystkich funkcji jest skatalogowana i dostępna w menu Formuły

najważniejsze funkcje Excel

2. Gdy zaczniemy wpisywać nazwę funkcji podpowiada się wyszukiwanie po użytej frazie

najważniejsze funkcje Excel

3. Nie potrzeba pamiętać dokładnej składni funkcji, zawsze jest podpowiedź. Po wpisywaniu nazwy funkcji można użyć skrótu do pomocy przy budowie argumentów. Ten kreator poprowadzi krok po kroku jak skonstruować funkcję.

najważniejsze funkcje Excel

Oto moje TOP 10, kolejność jest związana częstotliwością używania:

Top 10 funkcji Excel












1. WYSZUKAJ PIONOWO (ENG: VLOOKUP)

Używa się gdy trzeba znaleźć elementy w tabeli lub w zakresie według wiersza. Na przykład: sprawdź cenę produktu przez numer ID lub znajdź nazwę pracownika na podstawie identyfikatora pracownika.


Przykład:

=WYSZUKAJ.PIONOWO(A1;B:C;2;0)

czyli:

=WYSZUKAJ.PIONOWO(co chcesz wyszukać; w którym miejscu chcesz się odszukać; numer kolumny w zakresie zawierającym wartość do zwrócenia; zwracanie przybliżonej lub dokładnej wartości — wskazanej jako 1/prawda lub 0/FAŁSZ).


Instrukcja z video:

https://support.microsoft.com/pl-pl/office/wyszukaj-pionowo-funkcja-0bbc8083-26fe-4963-8ab8-93a18ad188a1


2. JEŻELI (ENG: IF)

Jest to tworzenie logicznych porównań wartości z oczekiwanymi wynikami. Może generować dwa wyniki. Pierwszy wynik otrzymamy, jeśli porównanie jest prawdziwe, a drugi — jeśli porównanie jest fałszywe.


Przykład:

=JEŻELI(C2="Tak";1;2)

czyli:

=JEŻELI(C2 = Tak, to zwróć wartość 1, a w przeciwnym razie zwróć wartość 2)


Instrukcja z video:

https://support.microsoft.com/pl-pl/office/je%C5%BCeli-funkcja-69aed7c9-4e8a-4755-a9bc-aa8bbff73be2


Bardzo często zagnieżdżam tu inne formuły. Np. jeżeli wynik jest prawidłowy, dokonaj danego obliczenia. W powyższym przypadku była by to sytuacja że jeżeli prawda, chcę wstawić komórkę A1 (zamiast 1) a jeżeli fałsz to sumę komórek od B1 do B6 (zamiast 2).

Czyli z formuły:

=JEŻELI(C2="Tak";1;2)

powstaje

=JEŻELI(C2="Tak";A1;SUMA(B1:B6))

Oczywiście można zagnieżdżać dłuższe bardziej skomplikowane funkcje, a nawet zagnieżdżać w zagnieżdżonych.


3. SUMA (ENG: SUM)

Prawdopodobnie najczęściej używana funkcja. Umożliwia dodawanie wartości we wskazanych zakresach komórkach. Można sumować zakresy z różnych arkuszy.

=SUMA(A2:A10) Dodaje wartości w komórkach od A2 do A10.

=SUMA(A2:A10 ; C2:C10) Dodaje wartości z komórek A2:10, a także komórki C2: C10.


Instrukcja z video:

https://support.microsoft.com/pl-pl/office/suma-funkcja-043e1c7d-7726-4e80-8f32-07b23e057f89



4. SUMA.WARUNKÓW (ENG: SUMIF)

W swoim działaniu bardzo zbliżona do funkcji SUMA. Podobnie jak w tamtym przypadku tak i w tym, celem obliczeń jest sumowanie wartości z oznaczonego zakresu. Różnica polega jedynie na możliwości określenia kryteriów, które będą brane pod uwagę podczas dokonywania obliczeń.


Funkcji SUMA.WARUNKÓW można użyć na przykład do zsumowania wartości sprzedaży danego produktu oraz w danym kraju.


Opiera się na 3 argumentach:

=SUMA.WARUNKÓW(suma_zakres;kryteria_zakres1;kryteria1;kryteria_zakres2;kryteria2)

  1. suma_zakres – to obszar komórek w obrębie których, sumowane będą wartości.

  2. kryteria_zakres1 – to zakres, który będzie sprawdzany na podstawie argumentu kryteria1 np. kolumna z grupami produktowymi

  3. kryteria1 – to warunek, który określa, które komórki z zakresu kryteria_zakres1 będą sumowane np. konkretna jedna grupa produktowa której wynik chcemy otrzymać

punkt 2 i 3 argument może być powtórzony nawet 127 razy


Instrukcja z video:

https://support.microsoft.com/pl-pl/office/suma-warunk%C3%B3w-funkcja-c9e748f5-7ea7-455d-9406-611cebce642b


5. LICZ.JEŻELI (ENG: COUNTIF)

Umożliwia policzenie liczby komórek, które spełniają dane kryteria. Można na przykład policzyć ile razy w tabeli obok występuje "handlowiec" albo ile jest osób powyżej 30. roku życia.


Formuła wygląda następująco:

=LICZ.JEŻELI(A2:A17;”handlowiec”)


Pierwszym argumentem jest zakres, a drugim poszukiwana fraza. Zamiast „handlowiec” można wstawić adres komórki, gdzie znajduje się ta wartość, np.:

=LICZ.JEŻELI(A2:A17;A17)


Instrukcja z video:

https://support.microsoft.com/pl-pl/office/licz-je%C5%BCeli-funkcja-e0de10c6-f885-4e71-abb4-1f464816df34


Aplikacje w Excelu sprawdź:



6. SUMA.JEŻELI (ENG: SUMIF)

Działa podobnie jak powyższa ale zamiast liczby wystąpień sumuje wartości z zakresu spełniającego określone kryteria. Załóżmy na przykład, że mają zostać zsumowane liczby z danej kolumny, które są większe od 5. W tym celu można zastosować następującą formułę: =SUMA.JEŻELI(B2:B17,">5")


Instrukcja z video:

https://support.microsoft.com/pl-pl/office/suma-je%C5%BCeli-funkcja-169b8c99-c05c-4483-a712-1697a653039b


7. ORAZ (ENG: AND)

Jedna z funkcji logicznych, pozwala sprawdzić, czy wszystkie warunki w teście mają wartość PRAWDA.


=ORAZ(A2>1;A2<100) formuła ta wskaże czy prawdą jest że wartość komórki A1 jest większa od 1 oraz mniejsza od 100.


Najczęściej używam z połączniem funkcji JEŻELI


=JEŻELI(ORAZ(A2<A3;A2<100);A2;"Wartość jest spoza zakresu")

Wyświetla wartość znajdującą się w komórce A2, jeśli jest ona mniejsza niż wartość znajdująca się w komórce A3 ORAZ mniejsza niż 100. W przeciwnym razie wyświetla komunikat „Wartość jest spoza zakresu”. W cudzysłowie możemy wpisać dowolny komunikat do wyświetlenia.


Instrukcja z video:

https://support.microsoft.com/pl-pl/office/oraz-funkcja-5f19b2e8-e1df-4408-897a-ce285a19e9d9


8. LUB (ENG: OR)

Także jedna z funkcji logicznych, aby sprawdzić, czy któryś z warunków w teście ma wartość PRAWDA.


=LUB(A2>1;A2<100) Wyświetla wartość PRAWDA, jeśli wartość w komórce A2 jest większa niż 1 LUB mniejsza niż 100. W przeciwnym razie wyświetla wartość FAŁSZ.


Także najczęściej używam z funkcjami warunkowymi, np. JEŻELI.


Funkcje ORAZ i LUB można stosować np. przy obliczaniu czy zostały spełnione warunki dla wypłaty premii w sprzedaży. Przykład:

- Gdy sprzedawcy muszą przekroczyć wartość docelową sprzedaży LUB wartość docelową marży

- Gdy sprzedawcy muszą przekroczyć wartość docelową sprzedaży ORAZ wartość docelową marży


Instrukcja:

https://support.microsoft.com/pl-pl/office/lub-funkcja-7d17ad14-8700-4281-b308-00b131e22af0


9. ZŁĄCZ TEKSTY (ENG: CONCATENATE)

Umożliwia połączenie dwóch lub więcej ciągów tekstowych w jeden ciąg.

Składnia:

=ZŁĄCZ.TEKSTY(tekst1;[tekst2];...)


W jakim celu się stosuje?

Na przykład estetycznym. Zamieszczenie imienia i nazwiska w jednej komórce, utworzenia klucza do wyszukiwania dla “WYSZUKAJ.PIONOWO”, sprawdzenia duplikatów wg dwóch kolumn etc.


Instrukcja:

https://support.microsoft.com/pl-pl/office/z%C5%82%C4%85cz-teksty-funkcja-8f8ae884-2ca8-4f7a-b093-75d702bea31d


W Office365 w jednej z aktualizacji pojawiła się nowa funkcja: ZŁĄCZ.TEKST. (bez "y" na końcu. Działa ona jak funkcja ZŁĄCZ.TEKSTY, umożliwiając również łączenie tekstów w Excelu poprzez zaznaczenie zakresu komórek. Jeśli chcesz połączyć tekst z komórek A1, A2, A3, A4, A5, A6, A7, A8 bez dokładania dodatkowych znaków (jak np. spacji między nimi) to Twoja formuła mogłaby wyglądać następująco:

1. Korzystając z nowej funkcji ZŁĄCZ.TEKST – =ZŁĄCZ.TEKST(A1:A8),

2. Korzystając ze starej funkcji ZŁĄCZ.TEKSTY – = ZŁĄCZ.TEKSTY(A1;A2;A3;A4;A5;A6;A7;A8).

Polecam przetestować!


Aplikacje w Excelu sprawdź:


10. JEŻELI BŁĄD (ENG: IFERROR)

Służy do zrealizowania obliczeń, jeżeli szukana przez nas wartość nie została wynaleziona.


Składnia:

=JEŻELI.BŁĄD(wartość;wartość_jeżeli_błąd)

=JEŻELI.BŁĄD(A2/B2;"Błąd w obliczeniach")


Stosuje się w przypadku gdy błąd #N/D! uniemożliwia kalkulację lub zapis wygląda nieestetycznie. Można zamiast tego zwrócić 0 lub puste pole (wpisując dwa cudzysłowy "")

Jeżeli podczas korzystania z funkcji WYSZUKAJ.PIONOWO pojawi się błąd #N/D!, to oznacza to, że funkcja nie znalazła odpowiedniego dopasowania. Jest to cenna informacja, ale jeśli w takiej formie pojawi się w raportach, to nie będzie to wyglądać elegancko. Z tego m.in. powodu Excel oferuje funkcje, które sprawdzają błędy i zwracają inne, określone przez użytkownika, wartości. Taką funkcją jest funkcja JEŻELI.BŁĄD.


Zamiast JEŻELI.BŁĄD, można użyć JEŻELI i testu logicznego.


Instrukcja:

https://support.microsoft.com/pl-pl/office/je%C5%BCeli-b%C5%82%C4%85d-funkcja-c526fd07-caeb-47b8-8bb6-63f3e417f611



Oprócz powyższego absolutną podstawą mojej pracy są tabele przestawne oraz dodatek Power Query (intuicyjna metoda na łączenie danych dzięki której korzystam z VBA co raz rzadziej)


Poprawę produktywności pracy o kilka % daje też korzystanie ze skrótów klawiszowych. Każdy zna kopiuj - wklej czyli Crl+C, Ctrl+V ale jest jeszcze kilka skrótów które przyspieszają prace. O tym już wkrótce na blogu.


Top 10 fukcji Excel - pobierz one-pager do druku:





Jeśli chcesz dowiedzieć się jak efektywnie używać Excela do monitorowania wyników sprzedażowych w firmie, umów się na bezpłatne konsultacje 🔽




1516 wyświetleń0 komentarzy

Ostatnie posty

Zobacz wszystkie